VGInterface.com
Search Downloads


Go Back   VGInterface > General Discussion > Interface Help

Reply
 
Thread Tools Display Modes
  #1  
Old 02-29-2008, 05:36 PM
Chagas Chagas is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Default "Spam" window spawns

I'm sunk on this problem. I'm currently running the latests Drox, but this problem began when I was running Core, so it seems to be UI independent.

I want to separate guild / group / tells into different windows. Not window tabs, but actual chat windows.

However I've found that every time I try to do this, certain things "seem" to happen.

1) Renaming chat windows causes a crash-to-desktop. Frequency: 99%

Upon returning to the game after crash the following is evident:

2) Windows have returned to their default settings "Chat 1, Chat 2, SPAM, Chat 3, etc.

Rinse and repeat if you try to re-name and re-assign them to specific channels. Lots of time, lost.

Now after the last few updates and quick-fix patches, I've found that when I crash I get a brand-spankin new "SPAM" tab on at LEAST one of my chat windows.

Guess what happens when I try to delte and/or rename and repurpose them?

Yes! Got it in one CTD FTW.

Any thoughts or suggestions would be appreciated. I'm actually startin to like Vent cuz the chat system is sooo clunky.
Reply With Quote
  #2  
Old 02-29-2008, 07:12 PM
Xndyr Xndyr is offline
Member
Interface Author - Click to view interfaces
 
Join Date: May 2007
Location: Arizona
Posts: 83
Default

pretty sure this is a client problem, not a UI problem. For the most part, no UI mods make any changes to the default chat window xml file. For my part, I looked at those files and they're so... fubar.. that i figured it wasn't worth it.

so, it could be a problem in the xml file for the chat window, or it's the way the client is working with the chat xml file. I know that I have seen the same type of behavior not just in myUI, but also in the default--but it's also been very sporatic for me. sometimes it happens, sometimes it doesn't.

but again, the short answer is: I think it's a problem with the vgclient.exe file itself.
Reply With Quote
  #3  
Old 03-02-2008, 03:50 PM
Chagas Chagas is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Default Update

Thanks for the info Xyn.

Update on Spam Window self-spawn...

Last night I decided to comment out some of my unused Drox windows, and when that seemed to have worked, I got ambitious and attempted to DELETE some of my self-spawned spam windows.

I deleted two of the four and discovered the following:

1) I have two spam tabs "burned-in" on my ui - they don't reveal/open a window, they just sit there, sorta like cat-prints on your screen.

2) CRASH to the desktop error file reveals ONLY an unrecoverable error, nothing more specific sadly.

3) Loading a saved UI from the 5 preset Drox saves restores chat windows as they were previously saved... as long as you don't try to rename them from the default "chat 1" "chat 2" etc.
Reply With Quote
  #4  
Old Today, 03:03 AM
Kahin Kahin is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Default

I experience the same issue.

Trying to get rid of it, I deleted the entire VGUIAssets folder and downloaded a fresh one via the patcher ... but it didn't work and loading a saved preset from DroxUI doesn't help neither.

I looked in every .ini and .xml file without success, does anyone has an idea where the chat window config is stored ?

Please, don't tell me it's server sided

Kahin
Reply With Quote
  #5  
Old Today, 05:45 AM
Kahin Kahin is offline
Junior Member
 
Join Date: Mar 2008
Posts: 2
Default

I was able to fix it by deleting the bin folder. I had to reconfigure everything but at least it works now.
Reply With Quote
  #6  
Old Today, 03:39 PM
Xndyr Xndyr is offline
Member
Interface Author - Click to view interfaces
 
Join Date: May 2007
Location: Arizona
Posts: 83
Default

Quote:
Originally Posted by Kahin
I was able to fix it by deleting the bin folder. I had to reconfigure everything but at least it works now.
The bin folder is where the client saves all the window configuration files, so it makes sense that deleting this folder would help with the situation. the file that most likely contained the information you were trying to delete was probably vgwindows.xml. that's where the layout of your UI is saved--all the windows and such, so that chat window locations and settings would have been in this file. it's been my experience that this file is often the root of a lot of problems with the UI layout not saving or repositioning certain windows upon reloading the game.
Reply With Quote
  #7  
Old Today, 06:06 PM
Chagas Chagas is offline
Junior Member
 
Join Date: Jan 2007
Posts: 21
Default Chat Spam fixed

I managed to fix the "Chat Spam Bug" by switching over to Xnyder's "myUI."

Hmmm, was that plug to shameless?

On a side note, I haven't really messed with renaming the chat windows since I switched to myUI, since renaming those windows seemed to have caused my nights of "chat-window-hell."

Is the chat-window code in Vanguard just that bizzare that changing the name of the window is enough to send the ui into a death spin? I'm just curious.

Thanks for all the replies!

Chaga
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:04 PM.

Contact Us - VGInterface - Terms of Service - Privacy Statement - Top

Our Network
EQInterface | EQ2Interface | WoWInterface | VGInterface | LoTROInterface | MMOInterface